Blank page trying to setup


#1

Hi all. Just installed 2.0.4 (fresh install) – Installed the .NET Core runtime, restarted IIS, all good.
I get the initial page to input the password from the appconfig.json file, it accepts that, holds for a second, then I get nothing. Just a blank page, 112bytes long, but 200 OK.

I’ve set log level to debug, made a logs folder, and got output, but it doesn’t show any errors.

Something you’ve seen before? The only thing that seems different between my setup and the guide is that my database is remote (and not using windows auth), but I’ve got a valid connection string, and it’s copy/paste from another application, has permissions to the newly made coderr DB (tested the creds in SSMS, I can make tables, etc.) – Checked permissions on the files in the site, all good too.

Any ideas where to start?


#2

Can you open web.config and change the stdoutLogEnabled to true?
Also change the stdoutLogFile path to a folder where the app pool has write permissions.

It’s dotnet cores own logfile which prints things that a MVC application can’t.


#3

Thanks for the tip! I’d already set that and reviewed the log, and while I guess I’m not expert, i don’t see anything odd logged there.
I’ve uploaded it to PasteBin:
https://pastebin.com/dywwhiZX

See anything there that stands out as something I’ve done wrong?


#4

I’ve tried several things and I cannot reproduce it.

Do note that it’s not “.NET core” but “.NET Core Hosting bundle” (v2.0.6) that you should install before.

This page:
https://www.microsoft.com/net/download/dotnet-core/runtime-2.0.6

Search for “Hosting Bundle Installer”.

If you have already installed that one, can you specify which version? Another user also got a blank page, but in his case it was due to a invalid connection string. In the latest beta I have added a timeout for the connection check.


#5

Would you mind trying the new beta? https://github.com/coderrio/Coderr.Server/releases/tag/v2.0-beta06


#6

Sure can. Installed the latest beta, no change to the behaviour. Looking at the .NET Core Web Hosting Bundle though, it appears I have installed the 2.0.7 package, not the 2.0.6 one.
So I’ve just uninstalled 2.0.7, installed 2.0.6 and restarted IIS as per you install notes.
Sadly, no change. A reboot of the host has also made no difference either.
Really the only thing I can see different here to your guides is that I’m using SQL logon details, rather than trusted connection on localhost.

from my AppSettings:
“ConnectionStrings”: {
“Db”: “Data Source=damstra-prod-sql.cyrmhzjtdjdq.ap-southeast-2.rds.amazonaws.com;Integrated Security=False;Initial Catalog=coderr;User ID=coderr;Password=******;MultipleActiveResultSets=True”
}

I’ve tried without the MARS parameter, I can connect to SQL with those credentials and have full database access.

I might try installing 1.x and see if that works … at least to rule it in/out…


#7

Well, yeah, v1 works fine. Was able to setup and configure the database, without issue. So certainly looks like a .NET Core related issue, but confused as to what. 2.0.6/2.0.7 of the runtime bundle didn’t make any difference, and outside of that, this is a pretty much bog standard EC2 AMI for Windows Server 2016.

Any other ideas to try? :slight_smile:


#8

Okay, final reply. I’ve got v2 working. Weirdly, it’s database setup related, if that helps you troubleshooting it.
With v1 working, I completed the setup, initialised the database etc. all went fine.
Then I switched to v2, and set the Configured to true. And perfect. Its 100% working now.

So if there is an existing DB, it seems fine, but for some reason, fails while attempting to create the DB, right after verifying the appsettings password. Hope it helps :slight_smile:


#9

Yes it help. Thank you a lot continuing to investigate, really appreciate it.

I’ll reply when I have figured out why it doesn’t work.